清泉逐流

做着努力,等待幸福到来
» 日志

解决Error executing aapt. Please check aapt is present at...错误

时间 : 2012-01-09 18:59 标签 : JDK  Eclipse  

  很久以前安装的Android开发环境,Eclipse的,今天突然要用一下,但是却老是出现

  Error executing aapt. Please check aapt is present at 。。。

  的错误,可是android sdk的路径是正确的呀,就很奇怪,上网查,看到下面的说明

  ===================================

根据指南先配置好JDK,和设置path,并且更新sdk要重新更改path,按照指南来还出现问题!

  Error executing aapt. Please check aapt is present at 。。。

    解决方案:在eclipse-->window-->属性-->android-->设置sdk的路径为解压缩的android_s

查看全文 »

Myeclipse编辑jsp保存中文出错

时间 : 2011-11-04 22:42 标签 : Eclipse  

  因为你在Myeclipse中编辑中文的编码是gbk的,而jsp默认的编码是iso8859-1的,所以会提示无法保存中文。

  PS,charset改的是客户端接收时浏览器的编码,而pageEncoding改的是jsp编译成servlet时用的编码。

  解决办法:

  在你的jsp页面最上面应该有一个<%@page %>标签,

  默认的标签的值应该是PageEncoding="ISO-8859-1"。把它改成GB2312再保存页面就可以了。

  如果没有这个标签,在JSP的第一行加上

  <%@page pageEncoding="gbk" %>

  或者

  <%@ page language="java" import="java.util.*" pageEncoding="utf-8"%>

  

查看全文 »

关于eclipse的jsp开环境配置和Myeclipse

时间 : 2011-11-04 15:58 标签 : Eclipse  

  关于有人说jsp开发环境是使用eclipse呢还是直接使用myeclipse呢,我觉得各有各的优点吧。

  个人感觉还是使用myeclipse比较好,那都是已经集成好的一些插件什么的,省的自己在eclipse上捣鼓过来捣鼓过去,还是弄不好,总是出现各种莫名其妙的问题。因为软件这东西本来就不是自己写的,要是出现一小点比如说版本什么的问题的话,总会是很让人崩溃,所以说,如果可以的话,个人开发最好还是用myeclipse。

  可能有人不同意,觉得使用eclipse再配上各种各样的插件,eclipse就成为了一个万能的开发工具。但是我觉得将各种不同类型的项目放在一个开发环境里面,也不是特别好吧。就比如说Zend Studio 也是基于eclipse的,但是还是蛮好用的。

  没事就码了这点问题,也不知道说了什么,就是想将自己的崩溃写在这里。

查看全文 »

Eclipse在Tomcat新建工程之后错误

时间 : 2011-11-04 11:09 标签 : Eclipse  Tomcat  

  上次配置Tomcat+Eclipse的开发环境,以前搭建过,所以觉得应该蛮顺利地。

  但是配置完,新建工程之后,发现了以下错误。

DescriptionResourcePathLocationType

  Project 'Frame' is missing required li

ary: 'C:\apache-tomcat-7.0.22\lib\common\jasper-runtime.jar'FrameBuild pathBuild Path Problem

  Project 'Frame' is mis

查看全文 »

Eclipse中JSP开发环境的搭建过程

时间 : 2011-10-30 11:39 标签 : Eclipse  

  首先讲一下环境配置,注意我配置的环境是在Windows2000 Server下的,不是Linux下的,配置的大致流程和操作系统无关,仅仅是在具体的安装上有差别。而配置成功与否,与操作系统无关。

    软件安装分为以下几个部分:

    1、 Java环境安装:

    这里使用的是J2SE 1.4.2,这个可以到sun公司的网站去下载:ttp://java.sun.com/j2se/1.4.2/download.html 。 

    为什么不用其他的版本呢?我也不清楚,不过公司里配置的标准版本就是这个版本,大概是因为兼容性的原因吧。 

    下载完成后,即可安装J2SE-SDK到E:\jsk目录下。  

    配置环境变量如下:  

    JAVA_HOME = E:\j

查看全文 »

@Override must override a superclass method

时间 : 2011-10-11 14:08 标签 : Eclipse  

在用Eclipse开发Java项目时,@Override 注解时会出现以下错误提示:

The method *** of type *** must override a superclass method

主要是因为该项目的Compiler comliance level的值设置不正确造成的,5.0是不支持@Override等注解,只要把它改为6.0就可以了,当然或者你也可以直接把注解@Override去掉。 

查看全文 »
» 日志标签